www.blafusel.de


  Home  |   Privat  |   Impressum  |   Bücher  |   Computer  |   Misc  |   OBD  |   Forum
Aktuelle Zeit: Montag 1. Juni 2020, 22:46

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 1 Beitrag ] 
Autor Nachricht
 Betreff des Beitrags: GOLF IV MSA-15 KW1281 probleem
BeitragVerfasst: Dienstag 18. Juni 2019, 13:54 
Offline

Registriert: Dienstag 18. Juni 2019, 13:47
Beiträge: 1
Hallo \:D/ , ik weet niet hoe ik Duits moet spreken, dus ik gebruik google vertaler, ik hoop dat er iets wordt begrepen. Ik heb een probleem dat me gek maakt, ik probeer bijna verbinding te maken met de besturingseenheid van mijn auto (MSA-15) die het KW1281-protocol gebruikt. Alles gebeurt via Arduino. Ik kan het juiste antwoord krijgen met succes (0x55, 0x01, 0x8A) maar dan verlies ik de contacten (ik lees dat we 0x75 moeten verzenden, maar het werkt niet). Heb je ideeën?

Ik dank je.

PS. Ik gebruik L9637D

Hier is diagram en schets:

//5 Baud Slow Init

digitalWrite(TX, HIGH);
delay(5000);
digitalWrite(TX, LOW);
delay(200);
digitalWrite(TX, HIGH);
delay(200);
digitalWrite(TX, LOW);
delay(1400);
digitalWrite(TX, HIGH);

Serial.println(F("##### Answer reading #####"));

for(byte n=0;n<6;n++)
{
Serial.print(softSerial.read(), HEX); //It answer correctly 0x55 0x01 0x8A
delay(500);
}


Bild


Nach oben
 Profil Private Nachricht senden  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 1 Beitrag ] 

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 19 Gäste


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de